JUnit tests fail with TYCHO

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

JUnit tests fail with TYCHO

Sandeep
Hi,

I try to build and test some eclipse plugins with "TYCHO 0.11.0".
The JUnit tests that pass when run in Eclipse, but only 2 of them pass (out of 10) when run with TYCHO.
These .tests plugins require 3.8.2 of JUnit.
The errors I get are,
      1 Java NULL Pointer Exception (for one test)
      2 junit.framework.AssertionFailedError: Class XYZ.tests.XXXTest has no public constructor TestCase(String name) or TestCase()

Can anyone help me with this.

I run my with

$mvn clean integration-test

My Test Plugin POM has
..
..
<build>
    <plugins>
      <plugin>
        <groupId>org.eclipse.tycho</groupId>
        <artifactId>maven-osgi-test-plugin</artifactId>
                <version>${tycho-version}</version>
       <configuration>
          <useUIHarness>true</useUIHarness>
        </configuration>
      </plugin>
    </plugins>
  </build>
..
..


Parent POM:
..
..
   <build>
             ..
             ..
                <plugin>
                        <groupId>org.sonatype.tycho</groupId>
                        <artifactId>maven-osgi-compiler-plugin</artifactId>
                        <version>${tycho-version}</version>
                        <configuration>
                                <source>1.6</source>
                                <target>1.6</target>
                        </configuration>
                </plugin>
             ..
             ..
   </build>
..
..







Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: JUnit tests fail with TYCHO

Tobias Oberlies
I can't answer this question, but you should try the new mailing list tycho-user at eclipse.org - it is watched by more people.

Also you should probably provide an example project to demonstrate your problem.

Regards
Tobias


> -----Original Message-----
> From: Sandeep [mailto:[hidden email]]
> Sent: 19 April 2011 15:33
> To: [hidden email]
> Subject: [Tycho Users] JUnit tests fail with TYCHO
>
> Hi,
>
> I try to build and test some eclipse plugins with "TYCHO 0.11.0".
> The JUnit tests that pass when run in Eclipse, but only 2 of them pass
> (out
> of 10) when run with TYCHO.
> These .tests plugins require 3.8.2 of JUnit.
> The errors I get are,
>       1 Java NULL Pointer Exception (for one test)
>       2 junit.framework.AssertionFailedError: Class XYZ.tests.XXXTest has
> no
> public constructor TestCase(String name) or TestCase()
>
> Can anyone help me with this.
>
> I run my with
>
> $mvn clean integration-test
>
> My Test Plugin POM has
> ..
> ..
> <build>
>     <plugins>
>       <plugin>
>         <groupId>org.eclipse.tycho</groupId>
>         <artifactId>maven-osgi-test-plugin</artifactId>
> <version>${tycho-version}</version>
>        <configuration>
>           <useUIHarness>true</useUIHarness>
>         </configuration>
>       </plugin>
>     </plugins>
>   </build>
> ..
> ..
>
>
> Parent POM:
> ..
> ..
>    <build>
>              ..
>              ..
> <plugin>
> <groupId>org.sonatype.tycho</groupId>
> <artifactId>maven-osgi-compiler-plugin</artifactId>
> <version>${tycho-version}</version>
> <configuration>
> <source>1.6</source>
> <target>1.6</target>
> </configuration>
> </plugin>
>              ..
>              ..
>    </build>
> ..
> ..
>
>
>
>
>
>
>
>
>
> --
> View this message in context: http://software.2206966.n2.nabble.com/JUnit-
> tests-fail-with-TYCHO-tp6287286p6287286.html
> Sent from the Tycho Users mailing list archive at Nabble.com.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: JUnit tests fail with TYCHO

Sandeep
Hi,

Thank you Tobias. I have mailed the mailing list, hope I will find a solution soon.

Regards,
Sandeep

On Wed, Apr 20, 2011 at 10:03 AM, Tobias Oberlies [via Software] <[hidden email]> wrote:
I can't answer this question, but you should try the new mailing list tycho-user at eclipse.org - it is watched by more people.

Also you should probably provide an example project to demonstrate your problem.

Regards
Tobias


> -----Original Message-----
> From: Sandeep [mailto:[hidden email]]
> Sent: 19 April 2011 15:33
> To: [hidden email]
> Subject: [Tycho Users] JUnit tests fail with TYCHO
>
> Hi,
>
> I try to build and test some eclipse plugins with "TYCHO 0.11.0".
> The JUnit tests that pass when run in Eclipse, but only 2 of them pass
> (out
> of 10) when run with TYCHO.
> These .tests plugins require 3.8.2 of JUnit.
> The errors I get are,
>       1 Java NULL Pointer Exception (for one test)
>       2 junit.framework.AssertionFailedError: Class XYZ.tests.XXXTest has
> no
> public constructor TestCase(String name) or TestCase()
>
> Can anyone help me with this.
>
> I run my with
>
> $mvn clean integration-test
>
> My Test Plugin POM has
> ..
> ..
> <build>
>     <plugins>
>       <plugin>
>         <groupId>org.eclipse.tycho</groupId>
>         <artifactId>maven-osgi-test-plugin</artifactId>
> <version>${tycho-version}</version>
>        <configuration>
>           <useUIHarness>true</useUIHarness>
>         </configuration>
>       </plugin>
>     </plugins>
>   </build>
> ..
> ..
>
>
> Parent POM:
> ..
> ..
>    <build>
>              ..
>              ..
> <plugin>
> <groupId>org.sonatype.tycho</groupId>
> <artifactId>maven-osgi-compiler-plugin</artifactId>
> <version>${tycho-version}</version>
> <configuration>
> <source>1.6</source>
> <target>1.6</target>
> </configuration>
> </plugin>
>              ..
>              ..
>    </build>
> ..
> ..
>
>
>
>
>
>
>
>
>
> --
> View this message in context: http://software.2206966.n2.nabble.com/JUnit-

> tests-fail-with-TYCHO-tp6287286p6287286.html
> Sent from the Tycho Users mailing list archive at Nabble.com.



If you reply to this email, your message will be added to the discussion below:
http://software.2206966.n2.nabble.com/JUnit-tests-fail-with-TYCHO-tp6287286p6289921.html
To unsubscribe from JUnit tests fail with TYCHO, click here.

Loading...