Status of Tycho m2eclipse support?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Status of Tycho m2eclipse support?

rgladwell
Hi Guys

Just reviewing this:

https://docs.sonatype.org/display/TYCHO/Dependency+on+pom-first
+artifacts

I notice it states that:

        There is currently no integration between Tycho and PDE build
        target platform management, and PDE will not be able to resolve
        pom-first dependencies of manifest-first project.
       
        Workaround is to import all pom-first dependencies into
        workspace as binary projects (File->Import->Plug-In
        Development->Plug-ins and Fragments). We are considering
        developing Tycho/M2E project configurator to address this
        limitation, but we do not know yet when and how this will
        happen.

I also notice that the Tycho M2E project is available from the
m2e-extras update site. However, installing this I can't get Eclipse to
recognise my maven-bundle-plugin dependencies.

Please, what is the status for POM-first dependenices in tycho-m2e?

TIA...

--
Ricardo Gladwell <[hidden email]>
http://www.google.com/profiles/ricardo.gladwell
Twitter: @rgladwell - MSN: [hidden email]



Reply | Threaded
Open this post in threaded view
|

Re: Status of Tycho m2eclipse support?

Igor Fedorenko-2
Dependency resolution from Tycho projects to *workspace*
maven-bundle-plugin projects is expected to work. If you can reproduce
the problem with recent m2e  0.13.0 build, please provide a sample
project(s) and we'll have a look. You can install recent m2e 0.13 from
one of subfolders of [1] and m2e-tycho installation is expected to
happen semi-automatically when you import tycho or maven-bundle-plugin
project for the first time.

Otherwise, we are limited by PDE and unless somebody contributes a
quality patch I do not expect any major new features introduced on the
current m2e-tycho codebase. I do have proof-of-concept kind or code
that uses drastically different approach to working on tycho and
maven-bundle-plugins inside Eclipse workspace, but I am not ready to
share this work just yet.

[1] https://repository.sonatype.org/content/sites/forge-sites/m2e/0.13.0/N/

--
Regards,
Igor

On Sat, Mar 12, 2011 at 7:46 AM, Ricardo Gladwell
<[hidden email]> wrote:

> Hi Guys
>
> Just reviewing this:
>
> https://docs.sonatype.org/display/TYCHO/Dependency+on+pom-first
> +artifacts
>
> I notice it states that:
>
>        There is currently no integration between Tycho and PDE build
>        target platform management, and PDE will not be able to resolve
>        pom-first dependencies of manifest-first project.
>
>        Workaround is to import all pom-first dependencies into
>        workspace as binary projects (File->Import->Plug-In
>        Development->Plug-ins and Fragments). We are considering
>        developing Tycho/M2E project configurator to address this
>        limitation, but we do not know yet when and how this will
>        happen.
>
> I also notice that the Tycho M2E project is available from the
> m2e-extras update site. However, installing this I can't get Eclipse to
> recognise my maven-bundle-plugin dependencies.
>
> Please, what is the status for POM-first dependenices in tycho-m2e?
>
> TIA...
>
> --
> Ricardo Gladwell <[hidden email]>
> http://www.google.com/profiles/ricardo.gladwell
> Twitter: @rgladwell - MSN: [hidden email]
>
>
>
>