Quantcast

can not find pakage org.service.obr 1.0.0

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

can not find pakage org.service.obr 1.0.0

manojlakhtariya
This post has NOT been accepted by the mailing list yet.
Hi guys .

I am new in maven/tycho and i m trying to build eclipse plug-in project with spring using tycho. when i try to build it gives me error missing package org.service.obr 1.0.0 here is my pom

<repositories>

                <repository>
                        <id>rxtx</id>
                        <url>http://rxtx.qbang.org/eclipse</url>
                        <layout>p2</layout>
                </repository>

                <repository>
                        <id>galileo</id>
                        <layout>p2</layout>
                        <url>http://download.eclipse.org/releases/galileo</url>
                </repository>
                <repository>
                        <id>equinox</id>
                        <url> http://download.eclipse.org/eclipse/updates/3.4milestones/</url>
                        <layout>p2</layout>
                </repository>

                <repository>
                        <id>rap</id>
                        <layout>p2</layout>
                        <url>http://download.eclipse.org/rt/rap/1.3/runtime</url>
                </repository>

               
        </repositories>

        <build>
                <plugins>
                        <plugin>
                                <groupId>org.apache.felix</groupId>
                                <artifactId>maven-bundle-plugin</artifactId>
                                <extensions>true</extensions>
                                <configuration>
                                        <excludeDependencies>*;scope=provided|runtime</excludeDependencies>
                                </configuration>
                        </plugin>
                        <plugin>
                                <groupId>org.sonatype.tycho</groupId>
                                <artifactId>tycho-maven-plugin</artifactId>
                                <version>${tycho-version}</version>
                                <extensions>true</extensions>
                        </plugin>


                        <plugin>
                                <groupId>org.sonatype.tycho</groupId>
                                <artifactId>maven-osgi-packaging-plugin</artifactId>
                                <version>${tycho-version}</version>
                                <configuration>
                                        <format>'v'yyyyMMdd-HHmm</format>
                                </configuration>
                        </plugin>
                        <plugin>
                                <groupId>org.sonatype.tycho</groupId>
                                <artifactId>maven-osgi-compiler-plugin</artifactId>
                                <version>${tycho-version}</version>
                        </plugin>



                        <plugin>
                                <groupId>org.sonatype.tycho</groupId>
                                <artifactId>target-platform-configuration</artifactId>
                                <version>${tycho-version}</version>
                                <configuration>
                                        <resolver>p2</resolver>
                                        <environments>
                                                <environment>
                                                        <os>linux</os>
                                                        <ws>gtk</ws>
                                                        <arch>x86</arch>
                                                </environment>
                                                <environment>
                                                        <os>linux</os>
                                                        <ws>gtk</ws>
                                                        <arch>x86_64</arch>
                                                </environment>
                                                <environment>
                                                        <os>win32</os>
                                                        <ws>win32</ws>
                                                        <arch>x86</arch>
                                                </environment>
                                                <environment>
                                                        <os>win32</os>
                                                        <ws>win32</ws>
                                                        <arch>x86_64</arch>
                                                </environment>
                                                <environment>
                                                        <os>macosx</os>
                                                        <ws>cocoa</ws>
                                                        <arch>x86_64</arch>
                                                </environment>
                                        </environments>
                                        <target>
                                                <artifact>
                                                        <groupId>${project.groupId}</groupId>
                                                        <artifactId>${project.artifactId}</artifactId>
                                                        <version>${project.version}</version>
                                                        <classifier>org.rifidi.edge</classifier>
                                                </artifact>
                                        </target>
                                        <ignoreTychoRepositories>true</ignoreTychoRepositories>
                                </configuration>
                        </plugin>

                </plugins>
        </build>

</project>



I am using tycho 0.11.0 version.

how can i say build process that missing jar is at some location org.osgi.service.obr1.0.0.jar??

do i need to create p2 repository for that and if yes then how can i create one and add it to pom ??


Thanks
Loading...