tycho and spring-dm - spring bundles repository problem

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

tycho and spring-dm - spring bundles repository problem

tom.bujok
This post has NOT been accepted by the mailing list yet.
Hi,

Does anyone know how to configure tycho to work with spring enterprise bundle repository?
I am struggling to add dependencies to spring-dm on the manifest level.

My configuration looks as follows
1.) in main pom.xml I added:
<repository>
                        <id>com.springsource.repository.bundles.release</id>
                        <name>SpringSource Enterprise Bundle Repository - SpringSource Bundle Releases</name>
                        <url>http://repository.springsource.com/maven/bundles/release</url>
                </repository>
                <repository>
                        <id>com.springsource.repository.bundles.external</id>
                        <name>SpringSource Enterprise Bundle Repository - External Bundle Releases</name>
                        <url>http://repository.springsource.com/maven/bundles/external</url>
                </repository>
2.) in the eclipse-plugin pom.xml I added:
<dependency>
                        <groupId>org.springframework.osgi</groupId>
                        <artifactId>org.springframework.osgi.core</artifactId>
                        <version>1.2.1</version>
                </dependency>

2.) in the manifest.mf of the eclipse plugin I added:
Required-Bundles: org.springframework.osgi.core

but I get an exception which looks like this:
[ERROR] Internal error: java.lang.RuntimeException: "No solution found because the problem is unsatisfiable.": ["Unable to satisfy dependency from XXX 1.0.0 to bundle
org.springframework.osgi.core 0.0.0.", "No solution found because the problem is unsatisfiable."] -> [Help 1]
org.apache.maven.InternalErrorException: Internal error: java.lang.RuntimeException: "No solution found because the problem is unsatisfiable.": ["Unable to satisfy dependency from XXX 1.0.0 to bundle org.springframework.osgi.core 0.0.0.", "No solution found because the problem is unsatisfiable."]
        at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:168)


What am I doing wrong?
Any help appreciated.

Thanks,
Tom




Loading...